App Fails To Deploy to Teams Catalog Due to Policies

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Issue : App Fails To Deploy to Teams Catalog Due to Microsoft Migration

Cause

An issue related to Microsoft’s migration to use App Centric Management causes an error when deploying apps to the Teams catalog. This issue results in an error like the one in the image below.

Solution

While waiting for Microsoft’s permanent fix, the following workaround can be done for app deployment:

  1. When an app is deployed:

    • If the app is available in the catalog, it will be deployed immediately.

    • If the app is not available in the catalog, the status is set to Pending Catalog Verification. In addition, the spinner icon displays CATALOG VERIFICATION IN PROGRESS when hovered over.

  2. Enterprise Admins can log in and click Verify [service name] App under the Action Required column. They need to click it periodically until it completes and disappears. When doing this, please ensure that they are using the Chrome browser.

  3. When the app is available in the catalog, it completes the verification and is deployed as it used to.

NOTE

This workaround flow deploys the app within 48 hours instead of not being deployed at all.