Problem
Direct Routing has been in progress for over an hour but is not completing. The dashboard looks like this:
Cause
This sometimes happens if Microsoft's servers are experiencing heavier traffic than usual. The process times out halfway through and then gets stuck.
Solution
From the left navigation pane, click on Direct Routing page. Re-initiate the direct routing process by clicking on the Finish button in the In Progress Direct Routing Details table.
If after an hour the Calling Enabled in the Dashboard still shows, proceed with step 2.
Open a ticket with ConnecttoTeams Support so we can un-freeze the process. Once we do, have the Microsoft Global Administrator login and retry direct routing by repeating step 1 above.